Re: [PATCH v4 3/4] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region()

From: Kees Cook
Date: Sun Jul 09 2017 - 10:02:54 EST


On Sun, Jul 9, 2017 at 5:37 AM, Baoquan He <bhe@xxxxxxxxxx> wrote:
> Now process_e820_entry() is not limited to e820 entry processing, rename
> it to process_mem_region(). And adjust the code comment accordingly.
>
> Signed-off-by: Baoquan He <bhe@xxxxxxxxxx>

Acked-by: Kees Cook <keescook@xxxxxxxxxxxx>

-Kees

> ---
> arch/x86/boot/compressed/kaslr.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c
> index 36ff9f729c43..99c7194f7ea6 100644
> --- a/arch/x86/boot/compressed/kaslr.c
> +++ b/arch/x86/boot/compressed/kaslr.c
> @@ -479,7 +479,7 @@ static unsigned long slots_fetch_random(void)
> return 0;
> }
>
> -static void process_e820_entry(struct mem_vector *entry,
> +static void process_mem_region(struct mem_vector *entry,
> unsigned long minimum,
> unsigned long image_size)
> {
> @@ -517,7 +517,7 @@ static void process_e820_entry(struct mem_vector *entry,
> /* Potentially raise address to meet alignment needs. */
> region.start = ALIGN(region.start, CONFIG_PHYSICAL_ALIGN);
>
> - /* Did we raise the address above this e820 region? */
> + /* Did we raise the address above the passed in memory entry? */
> if (region.start > cur_entry.start + cur_entry.size)
> return;
>
> @@ -573,7 +573,7 @@ static void process_e820_entries(unsigned long minimum,
> continue;
> region.start = entry->addr;
> region.size = entry->size;
> - process_e820_entry(&region, minimum, image_size);
> + process_mem_region(&region, minimum, image_size);
> if (slot_area_index == MAX_SLOT_AREA) {
> debug_putstr("Aborted e820 scan (slot_areas full)!\n");
> break;
> --
> 2.5.5
>



--
Kees Cook
Pixel Security