Re: [PATCH v2 3/4] btrfs: Add zstd support

From: Austin S. Hemmelgarn
Date: Mon Jul 10 2017 - 08:37:09 EST

On 2017-07-07 23:07, Adam Borowski wrote:
On Sat, Jul 08, 2017 at 01:40:18AM +0200, Adam Borowski wrote:
On Fri, Jul 07, 2017 at 11:17:49PM +0000, Nick Terrell wrote:
On 7/6/17, 9:32 AM, "Adam Borowski" <kilobyte@xxxxxxxxxx> wrote:
Got a reproducible crash on amd64:

Thanks for the bug report Adam! I'm looking into the failure, and haven't
been able to reproduce it yet. I've built my kernel from your tree, and
I ran your script with the kernel.tar tarball 100 times, but haven't gotten
a failure yet.

I have a few questions to guide my debugging.

- How many cores are you running with? Iâve run the script with 1, 2, and 4 cores.
- Which version of gcc are you using to compile the kernel? Iâm using gcc-6.2.0-5ubuntu12.
- Are the failures always in exactly the same place, and does it fail 100%
of the time or just regularly?

6 cores -- all on bare metal. gcc-7.1.0-9.
Lemme try with gcc-6, a different config or in a VM.

I've tried the following:
* gcc-6, defconfig (+btrfs obviously)
* gcc-7, defconfig
* gcc-6, my regular config
* gcc-7, my regular config
* gcc-7, debug + UBSAN + etc
* gcc-7, defconfig, qemu-kvm with only 1 core

Every build with gcc-7 reproduces the crash, every with gcc-6 does not.

Got a GCC7 tool-chain built, and I can confirm this here too, tested with various numbers of cores ranging from 1-32 in a QEMU+KVM VM, with various combinations of debug options and other config switches.