Re: [PATCH 1/4] can: dev: Add support for limiting configured bitrate
From: Oliver Hartkopp
Date: Thu Jul 20 2017 - 03:43:38 EST
Hi Franklin,
On 07/20/2017 01:36 AM, Franklin S Cooper Jr wrote:
+#ifdef CONFIG_OF
+void of_transceiver_is_fixed(struct net_device *dev)
+{
(..)
+}
+EXPORT_SYMBOL(of_transceiver_is_fixed);
+#endif
I'm not sure about the naming here.
As this is a CAN transceiver related option it should be named accordingly:
E.g.
can_transceiver_is_fixed
of_can_transceiver_is_fixed
...
Especially as it is defined in include/linux/can/dev.h
Regards,
Oliver