Re: Query: rcu_sched detected stalls with function_graph tracer

From: Steven Rostedt
Date: Wed Aug 02 2017 - 07:56:58 EST

On Wed, 2 Aug 2017 12:02:21 +0530
Pratyush Anand <panand@xxxxxxxxxx> wrote:

> Hi Steve,
> I am using a 3.10 based kernel, and when I enable function_graph with one
> particular x86_64 machine, I encounter rcu_sched stall.
> echo function_graph > /sys/kernel/debug/tracing/current_tracer
> echo 1 > /sys/kernel/debug/tracing/tracing_on
> If I use 4.13-rc2, then its better, but still goes for it after a bit of
> stressing with stressng.
> It looks like that this behavior should be expected with a loaded system (like
> that of ftrace-graph tracing for all available function) which can cause RCU
> stall warning. But,I am not an expert. So, whats your opinion on it?
> I tried to bisect and there was no particular function which can cause this.
> It looked like that when we had more than 5000 functions in set_ftrace_filter,
> we start getting such warnings. Tried by putting some most hit functions like
> spin_lock* etc in set_ftrace_notrace. Still, no help. Do you have some
> suggestion for further debugging pointers?
> log with 3.10 based kernel

Can you send me the config. I'm also guessing that this is a RHEL 3.10
based kernel (which means it's not 3.10 at all).

-- Steve