On 14/08/2017 16:32, Yu Zhang wrote:
No, I think those are best left in mmu.h. They are only used in mmu
On 8/14/2017 10:13 PM, Paolo Bonzini wrote:
On 14/08/2017 13:37, Yu Zhang wrote:Thanks, Paolo. How about we also move the definition of PT64_ROOT_4LEVEL/
Thanks a lot for your comments, Paolo. :-)Yes, you're right. I think the solution is to define
On 8/14/2017 3:31 PM, Paolo Bonzini wrote:
On 12/08/2017 15:35, Yu Zhang wrote:Well, I had tried, but failed to find a neat approach to do so. The
struct rsvd_bits_validate {Can you change this 4 to PT64_ROOT_MAX_LEVEL in patch 2?
- u64 rsvd_bits_mask[2][4];
+ u64 rsvd_bits_mask[2][5];
u64 bad_mt_xwr;
};
difficulty I have met is that PT64_ROOT_MAX_LEVEL is defined together
with PT64_ROOT_4LEVEL/PT32E_ROOT_LEVEL/PT32_ROOT_LEVEL in mmu.h, yet
the rsvd_bits_validate structure is defined in kvm_host.h, which are
included in quite a lot .c files that do not include mmu.h or include
the mmu.h after kvm_host.h.
I guess that's the reason why the magic number 4 instead of
PT64_ROOT_4LEVEL is used in current definition of
rsvd_bits_vadlidate. :-)
PT64_ROOT_MAX_LEVEL in kvm_host.h.
PT32E_ROOT_LEVEL/PT32_ROOT_LEVEL from mmu.h to kvm_host.h? Then we
can define PT64_ROOT_MAX_LEVEL as PT64_ROOT_4LEVEL instead of 4 in
kvm_host.h.
files, except for two occurrences in svm.c.
kvm_host.h would have PT64_ROOT_MAX_LEVEL just because it is slightly
better than "4" or "5".