[PATCH v2] staging: ks7010: Fix coding style and remove checkpatch.pl warnings.
From: Jonathan Whitaker
Date: Tue Aug 29 2017 - 22:58:07 EST
It is prefered to use '"%s...", __func__ instead of function names for
logging. This commit replaces hardcoded function name strings to the
more preferred '"%s...", __func__' style. These warnings were reported
by checkpatch.pl.
Signed-off-by: Jonathan Whitaker <jon.b.whitaker@xxxxxxxxx>
Changes in v2:
- Wrapped the changelog text to 72 columns.
- Fixed the commit subject to be more clear.
---
drivers/staging/ks7010/ks7010_sdio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c b/drivers/staging/ks7010/ks7010_sdio.c
index 9b28ee1..c0e91c3 100644
--- a/drivers/staging/ks7010/ks7010_sdio.c
+++ b/drivers/staging/ks7010/ks7010_sdio.c
@@ -834,7 +834,7 @@ static int ks7010_sdio_probe(struct sdio_func *func,
unsigned char byte;
int ret;
- DPRINTK(5, "ks7010_sdio_probe()\n");
+ DPRINTK(5, "%s()\n", __func__);
priv = NULL;
netdev = NULL;
@@ -1008,7 +1008,7 @@ static void ks7010_sdio_remove(struct sdio_func *func)
struct ks_sdio_card *card;
struct ks_wlan_private *priv;
- DPRINTK(1, "ks7010_sdio_remove()\n");
+ DPRINTK(1, "%s()\n", __func__);
card = sdio_get_drvdata(func);
--
2.7.4