Re: [PATCH RFC 5/6] Switch SPI driver calls its own driver switch register function

From: Andrew Lunn
Date: Thu Sep 07 2017 - 17:40:45 EST


On Thu, Sep 07, 2017 at 09:09:22PM +0000, Tristram.Ha@xxxxxxxxxxxxx wrote:
> From: Tristram Ha <Tristram.Ha@xxxxxxxxxxxxx>
>
> SPI driver calls own specific switch register function.
> Shutdown callback function is added to reset switch to default state.
>
> Signed-off-by: Tristram Ha <Tristram.Ha@xxxxxxxxxxxxx>
> ---
> diff --git a/drivers/net/dsa/microchip/ksz_spi.c b/drivers/net/dsa/microchip/ksz_spi.c
> index c519469..d03eb83 100644
> --- a/drivers/net/dsa/microchip/ksz_spi.c
> +++ b/drivers/net/dsa/microchip/ksz_spi.c
> @@ -25,6 +25,8 @@
>
> #include "ksz_priv.h"
>
> +int ksz9477_switch_register(struct ksz_device *dev);

Hi Tristram

This should be placed in a header file somewhere, not here.

> +static void ksz_spi_shutdown(struct spi_device *spi) {
> + struct ksz_device *dev = spi_get_drvdata(spi);
> +
> + if (dev)
> + dev->dev_ops->reset(dev);

shutdown seems like a better name for this op, not reset.

> +}
> +
> static const struct of_device_id ksz_dt_ids[] = {
> { .compatible = "microchip,ksz9477" },
> {},
> @@ -207,6 +217,7 @@ static int ksz_spi_remove(struct spi_device *spi)
> },
> .probe = ksz_spi_probe,
> .remove = ksz_spi_remove,
> + .shutdown = ksz_spi_shutdown,
> };
>
> module_spi_driver(ksz_spi_driver);