Re: sysbench throughput degradation in 4.13+

From: Eric Farman
Date: Fri Sep 22 2017 - 12:12:54 EST

On 09/22/2017 11:53 AM, Peter Zijlstra wrote:
On Fri, Sep 22, 2017 at 11:03:39AM -0400, Eric Farman wrote:
Hi Peter, Rik,

With OSS last week, I'm sure this got lost in the deluge, so here's a
friendly ping.

Very much so, inbox is a giant trainwreck ;-)

My apologies. :)

I picked up 4.14.0-rc1 earlier this week, and still see the
degradation described above. Not really a surprise, since I don't see any
other commits in this area beyond the ones I mentioned in my original note.

Anyway, I'm unsure what else to try or what doc to pull to help debug this,
and would appreciate your expertise here. We can repro this pretty easily
as necessary to help get to the bottom of this.

Many thanks in advance,

Could you describe your sysbench setup? Are you running it on mysql or
postgresql, what other options?

MySQL. We've tried a few different configs with both test=oltp and test=threads, but both show the same behavior. What I have settled on for my repro is the following:

sudo sysbench --db-driver=mysql --mysql-host=localhost --mysql-user=root --mysql-db=test1 --max-time=180 --max-requests=100000000 --num-threads=8 --test=oltp prepare
sudo sysbench --db-driver=mysql --mysql-host=localhost --mysql-user=root --mysql-db=test1 --max-time=180 --max-requests=100000000 --num-threads=8 --test=oltp run

Have also some environments where multiple sysbench instances are run concurrently (I've tried up to 8, with db's test1-8 being specified), but doesn't appear to much matter either.

- Eric