Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding event configuration registers to more appropriate names.

From: Martin Kepplinger
Date: Sun Oct 01 2017 - 14:11:08 EST

On 2017-09-30 19:59, Jonathan Cameron wrote:
> On Wed, 27 Sep 2017 08:52:54 +0200
> Martin Kepplinger <martink@xxxxxxxxx> wrote:
>> Am 25.09.2017 12:40 schrieb Harinath Nampally:
>>> Improves code readability, no impact on functionality.
>>> Signed-off-by: Harinath Nampally <harinath922@xxxxxxxxx>
>>> ---
>> I'd prefer a shorter subject line here too, see patch 2/3
> Agreed. I'm unconvinced the change helps. Perhaps that is
> because I don't fully understand why you are making the change?

It's understandable for me. It simply uses "transient" and "ff_mt" in
order to describe sets of device-registers instead of "rising" and
"falling". That's more appropriate. I'd apply this if possible.

Even though it should be clear after reading the data sheet, this
particular issue sometimes gets confusing for people. Maybe a short
descriptive comment, pointing to the data sheet, would make sense?