Re: [PATCH 1/3] scsi: ufs: Change HCI marco to actual bit position

From: Bart Van Assche
Date: Mon Oct 02 2017 - 12:41:43 EST

On Sat, 2017-09-30 at 11:52 +0530, Alim Akhtar wrote:
> Currently UFS HCI uses UFS_BIT() macro to get various bit
> position for the hardware registers status bits. Which makes
> code longer instead of shorter. This macro does not improve
> code readability as well.
> Lets re-write these macro definition with the actual bit position.

Can the three patches in this series be combined into a single patch?

> -#define UFS_BIT(x) (1L << (x))
> [ ... ]
> +#define UFS_BIT(x) (1L << (x))

If you want to keep the three patches separate, please make sure that this
patch does not modify the UFS_BIT() definition. Please also fix the spelling
of the title of this patch (marco -> macro).