Re: [Part2 PATCH v5 08/31] KVM: Introduce KVM_MEMORY_ENCRYPT_REGISTER_REGION ioctl

From: Brijesh Singh
Date: Wed Oct 04 2017 - 13:18:39 EST

On 10/04/2017 10:19 AM, Borislav Petkov wrote:

+ struct kvm_enc_region)
+ struct kvm_enc_region)

Yuck, those are needlessly too long. They could be just as understandable if
they were called:

#define KVM_MEM_ENC_REG_REGION _IOR(KVMIO, 0xbb, struct kvm_enc_region)
#define KVM_MEM_ENC_UNREG_REGION _IOR(KVMIO, 0xbc, struct kvm_enc_region)

or so... I know, it'll need to change the qemu patches but it is more
compact this way, IMO, and you don't have to break the _IOR line.

Thanks for the patch Boris, I will take care of removing the wrapper
from kvm_vm_ioctl_mem_enc_op(). As per shorting the name is concerned,
if am open to suggestion. lets see if Paolo or Radim have any comments
on naming. If not, then I will shorten the name in next rev.