Re: [PATCH v3] irq_work: improve the flag definitions

From: Bartosz Golaszewski
Date: Tue Oct 10 2017 - 03:20:30 EST


2017-09-18 11:23 GMT+02:00 Bartosz Golaszewski <brgl@xxxxxxxx>:
> IRQ_WORK_FLAGS is defined simply to 3UL. This is confusing as it
> says nothing about its purpose. Define IRQ_WORK_FLAGS as a bitwise
> OR of IRQ_WORK_PENDING and IRQ_WORK_BUSY and change its name to
> IRQ_WORK_CLAIMED.
>
> While we're at it: use the BIT() macro for all flags.
>
> Signed-off-by: Bartosz Golaszewski <brgl@xxxxxxxx>
> ---
> v1 -> v2:
> - IRQ_WORK_LAZY is defined to 4UL which is BIT(2) not BIT(3)
>
> v2 -> v3:
> - rename IRQ_WORK_FLAGS to IRQ_WORK_CLAIMED
>
> include/linux/irq_work.h | 8 ++++----
> kernel/irq_work.c | 2 +-
> 2 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/include/linux/irq_work.h b/include/linux/irq_work.h
> index 47b9ebd4a74f..499b7f7159d6 100644
> --- a/include/linux/irq_work.h
> +++ b/include/linux/irq_work.h
> @@ -12,10 +12,10 @@
> * busy NULL, 2 -> {free, claimed} : callback in progress, can be claimed
> */
>
> -#define IRQ_WORK_PENDING 1UL
> -#define IRQ_WORK_BUSY 2UL
> -#define IRQ_WORK_FLAGS 3UL
> -#define IRQ_WORK_LAZY 4UL /* Doesn't want IPI, wait for tick */
> +#define IRQ_WORK_PENDING BIT(0)
> +#define IRQ_WORK_BUSY BIT(1)
> +#define IRQ_WORK_CLAIMED (IRQ_WORK_PENDING | IRQ_WORK_BUSY)
> +#define IRQ_WORK_LAZY BIT(2) /* Doesn't want IPI, wait for tick */
>
> struct irq_work {
> unsigned long flags;
> diff --git a/kernel/irq_work.c b/kernel/irq_work.c
> index bcf107ce0854..1b51c6bbb5d3 100644
> --- a/kernel/irq_work.c
> +++ b/kernel/irq_work.c
> @@ -36,7 +36,7 @@ static bool irq_work_claim(struct irq_work *work)
> */
> flags = work->flags & ~IRQ_WORK_PENDING;
> for (;;) {
> - nflags = flags | IRQ_WORK_FLAGS;
> + nflags = flags | IRQ_WORK_CLAIMED;
> oflags = cmpxchg(&work->flags, flags, nflags);
> if (oflags == flags)
> break;
> --
> 2.13.2
>

Gentle ping for 4.15.

Best regards,
Bartosz