Re: [PATCH] vmalloc: add __alloc_vm_area() for optimizing vmap stack
From: Konstantin Khlebnikov
Date: Wed Oct 11 2017 - 09:32:23 EST
On 08.10.2017 12:16, Christoph Hellwig wrote:
This looks fine in general, but a few comments:
- can you split adding the new function from switching over the fork
codeok
- at least kasan and vmalloc_user/vmalloc_32_user use very similar
patterns, can you switch them over as well?
I don't see why VM_USERMAP cannot be set right at allocation.
I'll add vm_flags argument to __vmalloc_node() and
pass here VM_USERMAP from vmalloc_user/vmalloc_32_user
in separate patch.
KASAN is different: it allocates shadow area for area allocated for module.
Pointer to module area must be pushed from module_alloc().
This isn't worth optimization.
- the new __alloc_vm_area looks very different from alloc_vm_area,
maybe it needs a better name? vmalloc_range_area for example?
__vmalloc_area() is vacant - this most low-level, so I'll keep "__".
- when you split an existing function please keep the more low-level
function on top of the higher level one that calls it.ok