From: Andrew Lunn
Sent: 19 October 2017 15:15
+/* Clear learned (non-static) entry on given port */
+static void alr_loop_cb_del_port_learned(struct lan9303 *chip, u32 dat0,
+ u32 dat1, int portmap, void *ctx)
+{
+ int *port = ctx;
You can get the value directly to make the line below more readable:
int port = *(int *)ctx;
You have to be a bit careful with this. You often see people
submitting patches taking away casts for void * pointers.
If they do that here, it should at least not compile...
So maybe do it in two steps?
int * pport = ctx;
int port = *pport;
IMHO it is best to define a struct for the 'ctx and then do:
..., void *v_ctx)
{
foo_ctx *ctx = v_ctx;
int port = ctx->port;
That stops anyone having to double-check that the *(int *)
is operating on a pointer to an integer of the correct size.
One of the syntax checkers probably ought to generate a warning
for *(integer_type *)foo since it is often a bug.
David