Re: [PATCH RFC v3 1/7] proc: add proc_fs_info struct to store proc information
From: Alexey Dobriyan
Date: Fri Nov 10 2017 - 05:26:40 EST
On 11/9/17, Djalal Harouni <tixxdz@xxxxxxxxx> wrote:
> +struct proc_fs_info {
> + struct pid_namespace *pid_ns;
> +};
> +static inline struct proc_fs_info *proc_sb(struct super_block *sb)
> +{
> + return sb->s_fs_info;
> +}
Can you rename this to "struct proc_super_block *" then?
That "info" suffix all over filesystems doesn't add much info itself
just more typing.
Ditto for "fs_info" identifiers.
> +extern inline struct proc_fs_info *proc_sb(struct super_block *sb)
> { return NULL;}
extern inline?