Re: [PATCH] USB: serial: ark3116.c: Remove unused TIOCSSERIAL case from ioctl
From: Oliver Neukum
Date: Wed Dec 13 2017 - 09:44:01 EST
Am Mittwoch, den 13.12.2017, 15:30 +0300 schrieb Mikhail Zaytsev:
> On Wed, 13 Dec 2017 12:40:48 +0100 Oliver Neukum <oneukum@xxxxxxxx> wrote:
>
> >
> > They give you nothing. If you are looking at a vendor ID nothing but the
> > bare number makes sense. You are just making peoples' life harder when
> > they have to look up that definition. A symbolic name is fine if it gives
> > meaning. Even if the information you give is that the value is magic
> > and therefore not understood. But a vendor ID is an arbitrary yet
> > meaningful number. There is no point in hiding it.
>
> Thanks. I hear you, Oliver. What about:
>
> - serstruct.baud_base = 460800;
>
> Is it a magic number? I think yes.
>
Hi,
yes sure. That is a candidate for a symbolic name. Though if you use
it once, I see no benefit, but it does not hurt either. The member
is named and that is the important thing.
A line like
if (rate > 38400) return -EINVAL;
is not so good
if (rate > MAX_BAUD) return -EINVAL;
better
But:
device->maxbaudrate = 38400
is better than
device->maxbaudrate = MAX_BAUD
You see the point?
Regards
Oliver