Re: [PATCH] bug.h: Work around GCC PR82365 in BUG()
From: Geert Uytterhoeven
Date: Tue Dec 19 2017 - 06:49:40 EST
On Tue, Dec 19, 2017 at 12:39 PM, Arnd Bergmann <arnd@xxxxxxxx> wrote:
> The name barrier_before_unreachable() is a bit suboptimal here,
> as it fails to describe the fact that it is needed for both
> __builtin_unreachable() and for calling noreturn functions. Any other
> suggestions would be welcome here.
/me joins bikeshedding...
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds