Re: [PATCH v6 0/2] KVM: MMU: fix kvm_is_mmio_pfn()

From: Paolo Bonzini
Date: Wed Dec 20 2017 - 05:13:07 EST


On 20/12/2017 08:29, Haozhong Zhang wrote:
> Some reserved pages, such as those from NVDIMM DAX devices, are not
> for MMIO, and can be mapped with cached memory type for better
> performance. However, the above check misconceives those pages as
> MMIO. Because KVM maps MMIO pages with UC memory type, the
> performance of guest accesses to those pages would be harmed.
> Therefore, we check the host memory type in addition and only treat
> UC/UC-/WC pages as MMIO.
>
> Changes in v6:
> * Rename the function in patch 1 to pat_immune_to_uc_mtrr().
> * Consider WC memory type in patch 1.
>
> Changes in v5:
> * Rename pat_pfn_is_uc() into pat_pfn_is_uc_or_uc_minus() to avoid
> confusion.
> * Drop converters between kvm_pfn_t and pfn_t, because they are not
> necessary. pat_pfn_is_uc_or_uc_minus() does not need flags in
> pfn_t, so we can only pass a raw unsigned long to it.
>
> Changes in v4:
> * Mask pfn_t and kvm_pfn_t specific flags in conversion.
>
> Changes in v3:
> * Move cache mode check to pat.c as pat_pfn_is_uc()
> * Reintroduce converters between kvm_pfn_t and pfn_t.
>
> Changes in v2:
> * Switch to lookup_memtype() to get host memory type.
> * Rewrite the comment in KVM MMU patch.
> * Remove v1 patch 2, which is not necessary in v2.
>
> Haozhong Zhang (2):
> x86/mm: add a function to check if a pfn is UC/UC-/WC
> KVM: MMU: consider host cache mode in MMIO page check
>
> arch/x86/include/asm/pat.h | 2 ++
> arch/x86/kvm/mmu.c | 13 ++++++++++++-
> arch/x86/mm/pat.c | 19 +++++++++++++++++++
> 3 files changed, 33 insertions(+), 1 deletion(-)
>

Thanks, I applied this series. I only changed the function name to
pat_pfn_immune_to_uc_mtrr.

Thanks,

Paolo