Re: [PATCH 1/2] Move kfree_call_rcu() to slab_common.c

From: Matthew Wilcox
Date: Thu Jan 04 2018 - 16:47:07 EST


On Thu, Jan 04, 2018 at 01:27:49PM -0800, Rao Shoaib wrote:
> On 01/04/2018 12:35 PM, Rao Shoaib wrote:
> > As far as your previous comments are concerned, only the following one
> > has not been addressed. Can you please elaborate as I do not understand
> > the comment. The code was expanded because the new macro expansion check
> > fails. Based on Matthew Wilcox's comment I have reverted rcu_head_name
> > back to rcu_head.
> It turns out I did not remember the real reason for the change. With the
> macro rewritten, using rcu_head as a macro argument does not work because it
> conflicts with the name of the type 'struct rcu_head' used in the macro. I
> have renamed the macro argument to rcu_name.
>
> Shoaib
> >
> > > +#define kfree_rcu(ptr, rcu_head_name) \
> > > +    do { \
> > > +        typeof(ptr) __ptr = ptr;    \
> > > +        unsigned long __off = offsetof(typeof(*(__ptr)), \
> > > +                              rcu_head_name); \
> > > +        struct rcu_head *__rptr = (void *)__ptr + __off; \
> > > +        __kfree_rcu(__rptr, __off); \
> > > +    } while (0)
> >
> > why do you want to open code this?

But why are you changing this macro at all? If it was to avoid the
double-mention of "ptr", then you haven't done that.