Hey Srini,Sure, I will respin this with your suggestions, except the 3v3 and 1v5 suffix due to the reasons below:
As there are no comments I'd propose to change the endpoint supplies to
more generic names.
Yep.+- vdda-1p8-supply:
+ Usage: required for msm8996
+ Value type: <phandle>
+ Definition: A phandle to the 1.8v analog power supply
+
This should be dropped, because it is part of the phy.
Why do we need suffix here? AFAIU, It does not add any value, instead it would confuse the users.
- vdda_phy-supply:
Usage: required for ipq/apq8064
Value type: <phandle>
@@ -189,6 +194,15 @@
Value type: <phandle>
Definition: A phandle to the analog power supply for IC which generates
reference clock
+- vddpe-supply:
+ Usage: optional
+ Value type: <phandle>
+ Definition: A phandle to the PCIe endpoint power supply
vddpe_3v3-supply
yes, I will get rid of them.
+
+- vddpe1-supply:
+ Usage: optional
+ Value type: <phandle>
+ Definition: A phandle to the PCIe endpoint power supply 1
vddpe_1v5-supply
- phys:
Usage: required for apq8084
@@ -205,6 +219,8 @@
Value type: <prop-encoded-array>
Definition: List of phandle and GPIO specifier pairs. Should contain
- "perst-gpios" PCIe endpoint reset signal line
+ - "pe_en-gpios" PCIe endpoint enable signal line
+ - "pe_en1-gpios" PCIe endpoint enable1 signal line
We don't need those gpios, the regulator driver will manipulate these
gpios when we call regulator_enable/disable.