Another approach is to use ~0UL if that is preferable.
Not the same, acpi_create_platform_device() does a bit more than> For sure, this particular segment is effectively same as part of>>> + list_for_each_entry(rentry, &resource_list, node)>> It has similarities with acpi_create_platform_device().
>>> + resources[count++] = *rentry->res;
>> I guess we can utilize existing code.
> acpi_create_platform_device():
copying the resources. If it indeed makes no hurt...
> list_for_each_entry(rentry, &resource_list, node)...I would go with helper.
> acpi_platform_fill_resource(adev, rentry->res,
> &resources[count++]);
> So is your idea to refactor this common segment into a helper function?
>>> + char *name = &acpi_indirect_io_mfd_cell[count].name[0];