Re: [PATCH v6 1/2] drivers: irqchip: pdc: Add PDC interrupt controller for QCOM SoCs

From: Lina Iyer
Date: Thu Feb 15 2018 - 15:31:19 EST


On Thu, Feb 15 2018 at 20:24 +0000, Thomas Gleixner wrote:
On Thu, 15 Feb 2018, Lina Iyer wrote:
On Mon, Feb 12 2018 at 13:40 +0000, Thomas Gleixner wrote:
> On Fri, 9 Feb 2018, Lina Iyer wrote:
> > +enum pdc_irq_config_bits {
> > + PDC_POLARITY_LOW = 0,
> > + PDC_FALLING_EDGE = 2,
> > + PDC_POLARITY_HIGH = 4,
> > + PDC_RISING_EDGE = 6,
> > + PDC_DUAL_EDGE = 7,
>
> My previous comment about using binary constants still stands. Please
> either address review comments or reply at least. Ignoring reviews is not
> an option.
>
> Aside of that I really have to ask about the naming of these constants. Are
> these names hardware register nomenclature? If yes, they are disgusting. If
> no, they are still disgusting, but should be changed to sensible ones,
> which just match the IRQ_TYPE naming convention.
>
> PDC_LEVEL_LOW = 000b,
> PDC_EDGE_FALLING = 010b,
> ....
>
>
Checkpatch doesn't like binary constants. I guess I will need to keep
the enum definitions in hex or decimal. I will remove the binary from
the comments though.

Well checkpatch is not always right.


commit 95e2c6023b0e4c8499fb521697f79215f69135fe
Author: Joe Perches <joe@xxxxxxxxxxx>
Date: Wed Jul 3 15:05:20 2013 -0700

checkpatch: warn when using gcc's binary constant ("0b") extension

The gcc extension for binary constants that start with 0b is only
supported with gcc version 4.3 or higher.

Can anything of this be compiled with gcc < 4.3?

I don't see a reason why this would be compiled with a older GCC. I am
okay with ignoring the checkpatch errors. I was just not sure if I
should.

Thanks,
Lina