* Jin Yao <yao.jin@xxxxxxxxxxxxxxx> wrote:
+#ifdef HAVE_DWARF_SUPPORT
+#ifdef HAVE_DWARF_GETLOCATIONS
+#ifdef NO_GLIBC
+#ifdef HAVE_GTK2_SUPPORT
+#ifdef HAVE_LIBAUDIT_SUPPORT
+#ifdef HAVE_LIBBFD_SUPPORT
+#ifdef HAVE_LIBELF_SUPPORT
+#ifdef HAVE_LIBNUMA_SUPPORT
+#ifdef NO_LIBPERL
+#ifdef NO_LIBPYTHON
+#ifdef HAVE_SLANG_SUPPORT
+#ifdef HAVE_LIBCRYPTO_SUPPORT
+#ifdef HAVE_LIBUNWIND_SUPPORT
+#ifdef HAVE_DWARF_SUPPORT
+#ifdef HAVE_ZLIB_SUPPORT
+#ifdef HAVE_LZMA_SUPPORT
+#ifdef HAVE_AUXTRACE_SUPPORT
+#ifdef HAVE_LIBBPF_SUPPORT
BTW., it would be nice at this point to fix those 3 outliers that have a negation
in their library support status macro:
+#ifdef NO_GLIBC
+#ifdef NO_LIBPERL
+#ifdef NO_LIBPYTHON
... and invert them back to the HAVE_* side of the logic:
+#ifdef HAVE_GLIBC
+#ifdef HAVE_LIBPERL
+#ifdef HAVE_LIBPYTHON
That should make all related code more consistent and more readable.
Thanks,
Ingo