Re: [PATCH 0/3 RESEND] namei: add follow_up_bind()

From: Linus Torvalds
Date: Thu Apr 05 2018 - 12:29:05 EST


On Thu, Apr 5, 2018 at 3:51 AM, Christian Brauner
<christian.brauner@xxxxxxxxxx> wrote:
>
> This series adds:
> - follow_up_bind() to namei.{c,h}
> - switches fs/nfsd/vfs.c:follow_to_parent() to use follow_up_bind()
> - switches fs/devpts/inode.c:devpts_mntget() to use follow_up_bind()

Hmm. Seems fair enough to me, although I wonder how much this really
helps. It does get rid of a duplicate code pattern, but:

4 files changed, 14 insertions(+), 5 deletions(-)

and while some of that is just the new comment, some of it is just "overhead".

It's also a bit odd how the new helper is marked "inline", but nobody
will inline it because it's not actually in the header file or any of
the isers in the same C file. So instead, it has to be exported. I
wonder if it should just be a trivial inline in <linux/namei.h>? Maybe
it originally was, and that's where the inline came from, and then
Christian decided to make it be by the regular "follow_up()" instead?

But with all that said, I certainly don't *mind* the patch series.

Al, I'm leaving this up to you, and expect to get it from your vfs
tree eventually. Or not.

Linus