Re: [PATCH 01/22] dma-debug: move initialization to common code
From: Christoph Hellwig
Date: Tue Apr 24 2018 - 03:34:04 EST
On Fri, Apr 20, 2018 at 11:23:43AM +0100, Robin Murphy wrote:
>> -void dma_debug_init(u32 num_entries)
>> +static int dma_debug_init(void)
>> + u32 num_entries;
> Maybe initialise it to PREALLOC_DMA_DEBUG_ENTRIES?
We initialize it down in an if/else clause which seems a little more clear
to me, at the cost of two extra lines of code. But I suspect I should
just go a little further and merge the global req_entries and the local
num_entries into a single variable with a better name.
> I think it's worth noting that for most users this now happens much earlier
> than before. In general that's probably good (e.g. on arm64 it should
> prevent false-positives from the Arm SMMU drivers under ACPI), and I can't
> imagine it's high-risk, but it is a behaviour change.
I'll mention this in the changelog, thanks!