On Tue, Apr 24, 2018 at 8:46 AM, Joel Fernandes <joel.opensrc@xxxxxxxxx> wrote:
On Tue, Apr 24, 2018 at 5:35 AM, Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:Aargh, I messed that up, I meant:
On Tue, Apr 24, 2018 at 12:19:07PM +0100, Valentin Schneider wrote:Both Viresh's and Valentin's patch looks lovely to me too. I couldn't
On 24/04/18 11:43, Peter Zijlstra wrote:I think the proposal was to put it before the for_each_domain() loop
On Tue, Apr 24, 2018 at 11:02:26AM +0100, Valentin Schneider wrote:True, I would've said the call to find_energy_efficient_cpu() ([1]) could
I'd argue making things easier to read is a non-negligible part as well.Right, so I don't object to either of these (I think); but it would be
good to see this in combination with that proposed EAS change.
simply be added to the if (sd) {} case, but...
entirely, however...
It does indeed appear I confused the two of you, it was Quentin playingI think you (valentin) wanted to side-step the entire domain loop in...this would change more things. Admittedly I've been sort of out of the loop
that case or something.
(no pun intended) lately, but this doesn't ring a bell. That might have been
the other frenchie (Quentin) :)
with that.
In any case, if there not going to be conflicts here, this all looks
good.
spot anything wrong with them either. One suggestion I was thinking
off is can we add better comments to this code (atleast label fast
path vs slow path) ?
Also, annotate the conditions for the fast/slow path with
likely/unlikely since fast path is the common case? so like:
if (unlikely(sd)) {
/* Fast path, common case */
...
} else if (...) {
/* Slow path */
}
if (unlikely(sd)) {
/* Slow path */
...
} else if (...) {
/* Fast path */
}