Re: [tip:timers/urgent] Revert: Unify CLOCK_MONOTONIC and CLOCK_BOOTTIME

From: Rafael J. Wysocki
Date: Wed Apr 25 2018 - 16:57:30 EST

On Wednesday, April 25, 2018 9:41:23 PM CEST Linus Torvalds wrote:
> On Wed, Apr 25, 2018 at 12:09 PM, Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
> > On Wed, 25 Apr 2018, Linus Torvalds wrote:
> >>
> >> I don't see the reported watchdog things, and I run systemd and I ran
> >> these patches.
> >
> > With suspend/resume?
> Yes. I run them on my laptop, and while I don't do a _lot_ of
> suspend/resume, I do some. My laptop right now is running a "just
> after rc1" kernel, and has been for the last week, and has a couple of
> suspends in that time. Type "closed my laptop, took it elsewhere,
> opened it again", so more than a few minutes.
> > Fair enough. Do the reporters have more information or do I have to chase
> > it down myself?
> I think reporters should just say what distro they are running, and
> systemd versions etc, and how they debugged this. Maybe the pattern is
> obvious.
> For the record, I just run plain F27, obviously with my own kernel
> (and a tweaked config, but it approaches just being a "make
> localmodconfig" of the distro config).

FWIW, I run (64-bit) OpenSUSE 42.3 on the failing machine (Acer Aspire S5) with
my own kernel (custom config based on the distro one).

The problem here is that the machine doesn't resume from S2R. It appears to
just hang somewhere around where we return to user space. However, to trigger
the issue it needs to stay in suspend for several minutes (not sure how many
exactly). If it is just back-to-back suspend/resume, it will resume correctly.