Re: [RFC][PATCH 00/13] Provide saturating helpers for allocation

From: Laura Abbott
Date: Wed May 09 2018 - 12:08:33 EST

On 05/08/2018 05:42 PM, Kees Cook wrote:
This is a stab at providing three new helpers for allocation size

struct_size(), array_size(), and array3_size().

These are implemented on top of Rasmus's overflow checking functions,
and the last 8 patches are all treewide conversions of open-coded
multiplications into the various combinations of the helper functions.


Obvious question (that might indicate this deserves documentation?)

What's the difference between

kmalloc_array(cnt, sizeof(struct blah), GFP_KERNEL);


kmalloc(array_size(cnt, struct blah), GFP_KERNEL);

and when would you use one over the other?