Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

From: Eduardo Habkost
Date: Thu May 17 2018 - 13:50:25 EST


On Thu, May 17, 2018 at 05:54:24PM +0300, Michael S. Tsirkin wrote:
> HINTS_DEDICATED seems to be somewhat confusing:
>
> Guest doesn't really care whether it's the only task running on a host
> CPU as long as it's not preempted.
>
> And there are more reasons for Guest to be preempted than host CPU
> sharing, for example, with memory overcommit it can get preempted on a
> memory access, post copy migration can cause preemption, etc.
>
> Let's call it KVM_HINTS_REALTIME which seems to better
> match what guests expect.
>
> Also, the flag most be set on all vCPUs - current guests assume this.
> Note so in the documentation.
>
> Signed-off-by: Michael S. Tsirkin <mst@xxxxxxxxxx>
> ---
> Documentation/virtual/kvm/cpuid.txt | 6 +++---
> arch/x86/include/uapi/asm/kvm_para.h | 2 +-
> arch/x86/kernel/kvm.c | 8 ++++----
> 3 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/Documentation/virtual/kvm/cpuid.txt b/Documentation/virtual/kvm/cpuid.txt
> index d4f33eb8..ab022dc 100644
> --- a/Documentation/virtual/kvm/cpuid.txt
> +++ b/Documentation/virtual/kvm/cpuid.txt
> @@ -72,8 +72,8 @@ KVM_FEATURE_CLOCKSOURCE_STABLE_BIT || 24 || host will warn if no guest-side
>
> flag || value || meaning
> ==================================================================================
> -KVM_HINTS_DEDICATED || 0 || guest checks this feature bit to
> - || || determine if there is vCPU pinning
> - || || and there is no vCPU over-commitment,
> +KVM_HINTS_REALTIME || 0 || guest checks this feature bit to
> + || || determine that vCPUs are never
> + || || preempted for an unlimited time,
> || || allowing optimizations

My understanding of the original patch is that the intention is
to tell the guest that it is very unlikely to be preempted, so it
can choose a more appropriate spinlock implementation. This
description implies that the guest will never be preempted, which
is much stronger guarantee.

Isn't this new description incompatible with existing usage of
the hint, which might include people who just use vCPU pinning
but no mlock?

--
Eduardo