On Sat, May 19, 2018 at 12:05 AM, Geert Uytterhoeven
<geert@xxxxxxxxxxxxxx> wrote:
On Fri, May 18, 2018 at 10:07 PM, Andy Shevchenko
<andy.shevchenko@xxxxxxxxx> wrote:
On Fri, May 18, 2018 at 8:53 PM, Laura Abbott <labbott@xxxxxxxxxx> wrote:
+ bits = mask + BITS_TO_LONGS(chip->ngpio);
+ memset(mask, 0, BITS_TO_LONGS(chip->ngpio) * sizeof(*mask));
Wouldn't be better
bitmap_zero(mask, chip->ngpio);
?
chip->ngpio is never const, so bitmap_zero() would always fall back to
plain memset().
Yes. But it also much more readable and understandable here.