RE: [External] Re: [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found

From: Ocean HY1 He
Date: Sun Aug 12 2018 - 22:53:47 EST




> -----Original Message-----
> From: Verma, Vishal L <vishal.l.verma@xxxxxxxxx>
> Sent: Saturday, August 11, 2018 7:46 AM
> To: Williams, Dan J <dan.j.williams@xxxxxxxxx>; ross.zwisler@xxxxxxxxxxxxxxx;
> oceanhehy@xxxxxxxxx; Jiang, Dave <dave.jiang@xxxxxxxxx>; lenb@xxxxxxxxxx;
> rjw@xxxxxxxxxxxxx
> Cc: linux-kernel@xxxxxxxxxxxxxxx; linux-nvdimm@xxxxxxxxxxxx; linux-
> acpi@xxxxxxxxxxxxxxx; Ocean HY1 He <hehy1@xxxxxxxxxx>
> Subject: [External] Re: [PATCH v2] ACPI: nfit: remove redundant assignment if
> nfit_mem found
>
>
> On Thu, 2018-08-02 at 04:44 -0400, oceanhehy@xxxxxxxxx wrote:
> > From: Ocean He <hehy1@xxxxxxxxxx>
> >
> > When nfit_mem is found via list_for_each_entry, it has already been
> > assigned valid value. There is no need to assign it again in the
> > following
> > codes.
> >
> > Signed-off-by: Ocean He <hehy1@xxxxxxxxxx>
> > ---
> > v1: https://patchwork.kernel.org/patch/10553277/
> > v2: Sorry for noise. I got an email problem, so I have to resend to
> > loop
> > linux-nvdimm@xxxxxxxxxxxxx
> >
> > drivers/acpi/nfit/core.c | 4 +---
> > 1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
> > index 7c47900..85dde54 100644
> > --- a/drivers/acpi/nfit/core.c
> > +++ b/drivers/acpi/nfit/core.c
> > @@ -1048,9 +1048,7 @@ static int __nfit_mem_init(struct
> > acpi_nfit_desc *acpi_desc,
> > break;
> > }
> >
> > - if (found)
> > - nfit_mem = found;
> > - else {
> > + if (!found) {
>
> Hi Ocean,
>
> While this is technically correct, the old way was easier to read. We
> loop through and find the matching handle. If we found one, then
> nfit_mem was whatever was found. If not, we allocate it.
>
> With this change, one has to go grok the list_for_.. loop to figure out
> where nfit_mem is coming from. I'd personally prefer to keep the
> existing way..
>
Hi Verma,

You're right that it took me some time to find out where nfit_mem
was found, when I look these codes at first.

It's reasonable to keep the existing way for well readability.

Thanks,
Ocean.
> > nfit_mem = devm_kzalloc(acpi_desc->dev,
> > sizeof(*nfit_mem),
> > GFP_KERNEL);
> > if (!nfit_mem)