RE: [PATCH 00/31] Introduced new Cadence USBSSP DRD Driver

From: Pawel Laszczak
Date: Tue Aug 21 2018 - 10:50:26 EST


USBSSP it's the project name and it was the reason for such prefix.

I agree with you that the shorter prefix could be better and we could get rid of some warnings reported by checkpatch. Currently we have more important issues related to testing and debugging driver so decision about change I leave for the feature. Such modification could be made as separate single patch.

> Hi,
> On Thu, Jul 19, 2018 at 06:57:33PM +0100, Pawel Laszczak wrote:
> > This patch set introduce new Cadence USBSSP DRD driver
> > to linux kernel.
> Does the driver have to use 'usbssp' as the controller prefix? Is 'ssp'
> acceptable? It would make the tons of variable names shorter and the
> code much cleaner to read.
> Regards,
> -Bin.