On Wed, 2018-08-29 at 21:35 +0100, John Whitmore wrote:
Rename the bit field element AdvCoding, as it causes a checkpatch issue
with CamelCase naming. As the element is not actually used in code it
has been renamed to 'not_used_adv_coding'.
The single line of code which initialises the bit has been removed,
as the field is unused.
This is a purely coding style change which should have no impact
on runtime code execution.
Other than the somewhat useful code style cleanups, is there
a point at which you will feel comfortable doing actual code
changes to this driver?
Perhaps support for the chipset could be converted to use
mac80211 and moved into the directory with the other realtek
drivers in drivers/net/wireless/realtek/rtl8xxxu/...
Larry? What do you think?