[PATCH v2 0/2] remoteproc: qcom: Rename adsp and mss drivers

From: Bjorn Andersson
Date: Fri Sep 14 2018 - 13:33:49 EST


As we're introducing a non-TZ based remoteproc driver for the ADSP in SDM845
the current naming scheme becomes cumbersome. Rename the existing drivers in
order to allow for the following:

qcom_q6v5_adsp - handle the non-TZ adsp subsystem
qcom_q6v5_mss - handles the self-authenticated modem
qcom_q6v5_pas - handles all TZ based "standard" subsystems
qcom_q6v5_wcss - handles the non-TZ wireless subsystem

Bjorn Andersson (2):
remoteproc: qcom: Rename Hexagon v5 PAS driver
remoteproc: qcom: Rename Hexagon v5 modem driver

drivers/remoteproc/Kconfig | 35 ++++++++++---------
drivers/remoteproc/Makefile | 4 +--
.../{qcom_q6v5_pil.c => qcom_q6v5_mss.c} | 0
.../{qcom_adsp_pil.c => qcom_q6v5_pas.c} | 4 +--
4 files changed, 22 insertions(+), 21 deletions(-)
rename drivers/remoteproc/{qcom_q6v5_pil.c => qcom_q6v5_mss.c} (100%)
rename drivers/remoteproc/{qcom_adsp_pil.c => qcom_q6v5_pas.c} (98%)

--
2.18.0