Re: [PATCH] clocksource/drivers/fttmr010: fix invalid interrupt register access
From: Linus Walleij
Date: Tue Oct 02 2018 - 03:35:18 EST
Hi Tao, thanks for your patch!
On Tue, Oct 2, 2018 at 6:14 AM Tao Ren <taoren@xxxxxx> wrote:
> - if (fttmr010->count_down)
> + if (fttmr010->count_down) {
> writel(~0, fttmr010->base + TIMER1_LOAD);
This struct member "count_down" is a bit badly named now don't
you think?
The patch is fine semantically, but please rename this member
"is_aspeed" or something like that and update the code everywhere,
then insert a comments like
/* The Aspeed variant counts downward */
/* The Aspeed variant does not have a match interrupt */
in the code snippets so we see what is going on.
Yours,
Linus Walleij