Re: [PATCH 2/5] remoteproc: Check for NULL firmwares in sysfs interface

From: Suman Anna
Date: Tue Oct 02 2018 - 11:06:05 EST


Hi Arnaud,

On 10/02/2018 04:43 AM, Arnaud Pouliquen wrote:
> Hi Suman,
>
> On 09/15/2018 02:37 AM, Suman Anna wrote:
>> The remoteproc framework provides a sysfs file 'firmware'
>> for modifying the firmware image name from userspace. Add
>> an additional check to ensure NULL firmwares are errored
>> out right away, rather than getting a delayed error while
>> requesting a firmware during the start of a remoteproc
>> later on.
>>
>> Signed-off-by: Suman Anna <s-anna@xxxxxx>
>> ---
>> drivers/remoteproc/remoteproc_sysfs.c | 5 +++++
>> 1 file changed, 5 insertions(+)
>>
>> diff --git a/drivers/remoteproc/remoteproc_sysfs.c b/drivers/remoteproc/remoteproc_sysfs.c
>> index 2142b3ea726e..ce93f4d710f3 100644
>> --- a/drivers/remoteproc/remoteproc_sysfs.c
>> +++ b/drivers/remoteproc/remoteproc_sysfs.c
>> @@ -49,6 +49,11 @@ static ssize_t firmware_store(struct device *dev,
>> }
>>
>> len = strcspn(buf, "\n");
>> + if (!len) {
>> + dev_err(dev, "can't provide a NULL firmware\n");
>> + err = -EINVAL;
>> + goto out;
>> + }

> This patch fixes only the case of a null name but not a bad name. So I'm
> not one hundred percent sure that it is relevant, as it treats only a
> part of the problem. But it's fine with me if it is accepted.

Yeah, it is a minor fix catching only NULL names. There is no way for
the interface to know a bad name until the corresponding firmware is
requested.

regards
Suman

>
> Tested-by: Arnaud Pouliquen <arnaud.pouliquen@xxxxxx>
>
> Regards
> Arnaud
>
>>
>> p = kstrndup(buf, len, GFP_KERNEL);
>> if (!p) {
>>