Re: [PATCH 07/10] swiotlb: refactor swiotlb_map_page

From: Konrad Rzeszutek Wilk
Date: Thu Oct 18 2018 - 20:37:45 EST


> > + if (!dma_capable(dev, dma_addr, size) ||
> > + swiotlb_force == SWIOTLB_FORCE) {
> > + trace_swiotlb_bounced(dev, dma_addr, size, swiotlb_force);
> > + dma_addr = swiotlb_bounce_page(dev, &phys, size, dir, attrs);
> > + }
>
> FWIW I prefer the inverse condition and early return of the original code
> here, which also then allows a tail-call to swiotlb_bounce_page() (and saves
> a couple of lines), but it's no biggie.
>
> Reviewed-by: Robin Murphy <robin.murphy@xxxxxxx>

I agree with Robin - it certainly makes it easier to read.

With that small change:
Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>

Thank you!

>
> > - return DIRECT_MAPPING_ERROR;
> > + return dma_addr;
> > }
> > /*
> >