How about changing that expression into the following to make it easier
for the compiler to optimize this code?
(offset | (bprv->bv_offset + bprv->bv_len)) & queue_virt_boundary(q)
Uhm I have to admit I'm not really able to parse the above expression.
Sure GCC will do it but I think it's less readable (at least for me).
Let's see what other's think.