Re: [patch V2 06/28] x86/speculation: Rename SSBD update functions

From: Konrad Rzeszutek Wilk
Date: Thu Nov 29 2018 - 09:37:47 EST

On Sun, Nov 25, 2018 at 07:33:34PM +0100, Thomas Gleixner wrote:
> During context switch, the SSBD bit in SPEC_CTRL MSR is updated according
> to changes of the TIF_SSBD flag in the current and next running task.
> Currently, only the bit controlling speculative store bypass disable in
> SPEC_CTRL MSR is updated and the related update functions all have
> "speculative_store" or "ssb" in their names.
> For enhanced mitigation control other bits in SPEC_CTRL MSR need to be
> updated as well, which makes the SSB names inadequate.
> Rename the "speculative_store*" functions to a more generic name.
> Signed-off-by: Tim Chen <tim.c.chen@xxxxxxxxxxxxxxx>
> Signed-off-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>

Thank you!