Re: [PATCH 13/18] asm-generic/tlb: Introduce HAVE_MMU_GATHER_NO_GATHER

From: Aneesh Kumar K.V
Date: Tue Dec 11 2018 - 00:43:20 EST

Peter Zijlstra <peterz@xxxxxxxxxxxxx> writes:

> From: Martin Schwidefsky <schwidefsky@xxxxxxxxxx>
> Add the Kconfig option HAVE_MMU_GATHER_NO_GATHER to the generic
> mmu_gather code. If the option is set the mmu_gather will not
> track individual pages for delayed page free anymore. A platform
> that enables the option needs to provide its own implementation
> of the __tlb_remove_page_size function to free pages.

Can we rename this to HAVE_NO_BATCH_MMU_GATHER?

> Cc: npiggin@xxxxxxxxx
> Cc: heiko.carstens@xxxxxxxxxx
> Cc: will.deacon@xxxxxxx
> Cc: aneesh.kumar@xxxxxxxxxxxxxxxxxx
> Cc: akpm@xxxxxxxxxxxxxxxxxxxx
> Cc: Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>
> Cc: linux@xxxxxxxxxxxxxxx
> Signed-off-by: Martin Schwidefsky <schwidefsky@xxxxxxxxxx>
> Signed-off-by: Peter Zijlstra (Intel) <peterz@xxxxxxxxxxxxx>
> Link: