A weird problem of Realtek r8168 after resume from S3

From: Chris Chiu
Date: Wed Dec 12 2018 - 21:20:51 EST

We got an acer laptop which has a problem with ethernet networking after
resuming from S3. The ethernet is popular realtek r8168. The lspci shows as
02:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)

The problem is the ethernet is not accessible after resume. Pinging via
ethernet always shows the response `Destination Host Unreachable`. However,
the interesting part is, when I run tcpdump to monitor the problematic ethernet
interface, the networking is back to alive. But it's dead again after
I stop tcpdump.
One more thing, if I ping the problematic machine from others, it achieves the
same effect as above tcpdump. Maybe it's about the register setting for RX path?

I tried the latest 4.20 rc version but the problem still there. I
also tried some
hw_reset or init thing in the resume path but no effect. Any
suggestion for this?