Re: use generic DMA mapping code in powerpc V4

From: Christian Zigotzky
Date: Thu Dec 13 2018 - 06:19:33 EST

On 13 December 2018 at 10:47AM, Christian Zigotzky wrote:
On 13 December 2018 at 10:10AM, Christoph Hellwig wrote:
On Thu, Dec 13, 2018 at 09:41:50AM +0100, Christian Zigotzky wrote:
Today I tried the first patch (0001-get_required_mask.patch) with the last
good commit (977706f9755d2d697aa6f45b4f9f0e07516efeda). Unfortunately this
patch is already included in the last good commit
(977706f9755d2d697aa6f45b4f9f0e07516efeda). I will try the next patch.
Hmm, I don't think this is the case. This is my local git log output:

commit 83a4b87de6bc6a75b500c9959de88e2157fbcd7c
Author: Christoph Hellwig <hch@xxxxxx>
Date:ÂÂ Wed Dec 12 15:07:49 2018 +0100

ÂÂÂÂ get_required_mask

commit 977706f9755d2d697aa6f45b4f9f0e07516efeda
Author: Christoph Hellwig <hch@xxxxxx>
Date:ÂÂ Sat Nov 10 22:34:27 2018 +0100

ÂÂÂÂ powerpc/dma: remove dma_nommu_mmap_coherent

I've also pushed a git branch with these out to:

ÂÂÂÂ git:// powerpc-dma.5-debug

Sorry Christioph. I was wrong. The first patch isn't included in the last good commit. I will try it again. I can only test beside my main work. That means it takes longer.

-- Christian

I tried it again but I get the following error message:

MODPOST vmlinux.o
arch/powerpc/kernel/dma-iommu.o: In function `.dma_iommu_get_required_mask':
(.text+0x274): undefined reference to `.dma_direct_get_required_mask'
make: *** [vmlinux] Error 1