Re: [PATCH v2] debugobjects: Move printk out of db lock critical sections

From: Linus Torvalds
Date: Mon Dec 17 2018 - 14:44:32 EST

On Mon, Dec 17, 2018 at 10:17 AM Ingo Molnar <mingo@xxxxxxxxxx> wrote:
> We should rename printk() to syslog() or so, and rename early_printk() to
> printk(), and be done with this.


As already pointed out, the syslog part isn't the issue. The printing
part is the issue.

So thinking that early_printk is any better is just puting your head
in the sand.