Re: [PATCH] lib/genalloc.c: rename addr_in_gen_pool to gen_pool_has_addr

From: Christoph Hellwig
Date: Fri Dec 28 2018 - 03:48:49 EST

On Fri, Dec 28, 2018 at 04:39:50PM +0800, Huang Shijie wrote:
> Follow the kernel conventions, rename addr_in_gen_pool to
> gen_pool_has_addr.

Which convention? The old name certainly looks more sensible to me.

If we really want to change anything about this function I'd suggest
to drop the size argument, as the address itself should describe the
region good enough.