Re: [RFC v2 0/6] x86: dynamic indirect branch promotion

From: Josh Poimboeuf
Date: Thu Jan 03 2019 - 13:11:12 EST

On Mon, Dec 31, 2018 at 07:53:06PM +0000, Nadav Amit wrote:
> > On Dec 31, 2018, at 11:51 AM, Andy Lutomirski <luto@xxxxxxxxxx> wrote:
> >
> > On Sun, Dec 30, 2018 at 11:20 PM Nadav Amit <namit@xxxxxxxxxx> wrote:
> >> This is a revised version of optpolines (formerly named retpolines) for
> >> dynamic indirect branch promotion in order to reduce retpoline overheads
> >> [1].
> >
> > Some of your changelogs still call them "relpolines".
> >
> > I have a crazy suggestion: maybe don't give them a cute name at all?
> > Where it's actually necessary to name them (like in a config option),
> > use a description like CONFIG_DYNAMIC_DEVIRTUALIZATION or

Cute or not, naming is important.

If you want a description instead of a name, it will be a challenge to
describe it in 2-3 words.

I have no idea what "dynamic devirtualization" means.

"Patch indirect calls" doesn't fully describe it either (and could be
easily confused with static calls and some other approaches).

> Iâm totally fine with that (donât turn me into a "marketingâ guy). It was
> just a way to refer to the mechanism. I need more feedback about the more
> fundamental issues to go on.

Naming isn't marketing. It's a real issue: it affects both usability
and code readability.