Re: [PATCH] i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc()
From: Wolfram Sang
Date: Fri Jan 04 2019 - 13:06:16 EST
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
I am okay with this patch in general. However, I think the name of the
helper 'struct_size' is a bit unfortunate. I really wondered on the
first read why it needs 3 arguments to find out a struct size. I only
understood on the second read. I think 'trailing_array_struct_size'
would be way more clearer what it does.
Description: PGP signature