[PATCH 1/2] kthread: Add __kthread_should_park()

From: Matthias Kaehlcke
Date: Mon Jan 28 2019 - 18:46:43 EST


The existing kthread_should_park() is used to check if the calling
kthread ('current') should park. The new __kthread_should_park()
receives a task_struct as parameter to check if the corresponding
kernel thread should be parked. Call __kthread_should_park() from
kthread_should_park() to avoid code duplication.

Signed-off-by: Matthias Kaehlcke <mka@xxxxxxxxxxxx>
---
I'm not overly happy about the function name with the double
underscore prefix, but couldn't come up with anything better. I'm
open to suggestions :)
---
include/linux/kthread.h | 1 +
kernel/kthread.c | 8 +++++++-
2 files changed, 8 insertions(+), 1 deletion(-)

diff --git a/include/linux/kthread.h b/include/linux/kthread.h
index c1961761311db..1577a2d56e9d4 100644
--- a/include/linux/kthread.h
+++ b/include/linux/kthread.h
@@ -56,6 +56,7 @@ void kthread_bind_mask(struct task_struct *k, const struct cpumask *mask);
int kthread_stop(struct task_struct *k);
bool kthread_should_stop(void);
bool kthread_should_park(void);
+bool __kthread_should_park(struct task_struct *k);
bool kthread_freezable_should_stop(bool *was_frozen);
void *kthread_data(struct task_struct *k);
void *kthread_probe_data(struct task_struct *k);
diff --git a/kernel/kthread.c b/kernel/kthread.c
index 087d18d771b53..65234c89d85b4 100644
--- a/kernel/kthread.c
+++ b/kernel/kthread.c
@@ -101,6 +101,12 @@ bool kthread_should_stop(void)
}
EXPORT_SYMBOL(kthread_should_stop);

+bool __kthread_should_park(struct task_struct *k)
+{
+ return test_bit(KTHREAD_SHOULD_PARK, &to_kthread(k)->flags);
+}
+EXPORT_SYMBOL_GPL(__kthread_should_park);
+
/**
* kthread_should_park - should this kthread park now?
*
@@ -114,7 +120,7 @@ EXPORT_SYMBOL(kthread_should_stop);
*/
bool kthread_should_park(void)
{
- return test_bit(KTHREAD_SHOULD_PARK, &to_kthread(current)->flags);
+ return __kthread_should_park(current);
}
EXPORT_SYMBOL_GPL(kthread_should_park);

--
2.20.1.495.gaa96b0ce6b-goog