Re: [PATCH] drm/vc4: Use struct_size() in kzalloc()

From: Gustavo A. R. Silva
Date: Thu Feb 07 2019 - 18:02:33 EST




On 2/7/19 4:59 PM, Eric Anholt wrote:
> "Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> writes:
>
>> One of the more common cases of allocation size calculations is finding
>> the size of a structure that has a zero-sized array at the end, along
>> with memory for some number of elements for that array. For example:
>>
>> struct foo {
>> int stuff;
>> void *entry[];
>> };
>>
>> instance = kzalloc(sizeof(struct foo) + count * sizeof(struct boo), GFP_KERNEL);
>>
>> Instead of leaving these open-coded and prone to type mistakes, we can
>> now use the new struct_size() helper:
>>
>> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>>
>> This code was detected with the help of Coccinelle.
>>
>> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>
>
> Reviewed and pushed to drm-misc-next. Thanks!
>

Thank you, Eric.

--
Gustavo