Re: [PATCH] include: mtd: spi-nor: change HWCPAS to HWCAPS

From: Tudor.Ambarus
Date: Fri Feb 08 2019 - 05:26:58 EST


Hi, Bean,

SNOR_HWCPAS_READ_OCTO was renamed to SNOR_HWCPAS_READ_OCTAL please update your
remote and send a new patch.

The patch prefix is wrong, it should be prefixed with "mtd: spi-nor:". When in
doubt, you can check how were prefixed previous patches on the same file by
running something like:

git log --oneline include/linux/mtd/spi-nor.h

On 02/07/2019 03:46 PM, Bean Huo (beanhuo) wrote:
>

This looks like a blank line, it's not needed, remove it please.
> Maybe this is wrong abbreviation, change from HWCPAS to HWCAPS.

Indeed, it is, use imperative, something like: "Fix wrong abbreviation,
s/HWCPAS/HWCAPS"
>
> Signed-off-by: Bean Huo <beanhuo@xxxxxxxxxx>

Your S-o-b tag doesn't match the author name, please fix this as well.

Cheers,
ta

> ---
> include/linux/mtd/spi-nor.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/mtd/spi-nor.h b/include/linux/mtd/spi-nor.h
> index fa2d89e..5e12bf9 100644
> --- a/include/linux/mtd/spi-nor.h
> +++ b/include/linux/mtd/spi-nor.h
> @@ -479,7 +479,7 @@ struct spi_nor_hwcaps {
> #define SNOR_HWCAPS_READ_4_4_4 BIT(9)
> #define SNOR_HWCAPS_READ_1_4_4_DTR BIT(10)
>
> -#define SNOR_HWCPAS_READ_OCTO GENMASK(14, 11)
> +#define SNOR_HWCAPS_READ_OCTO GENMASK(14, 11)
> #define SNOR_HWCAPS_READ_1_1_8 BIT(11)
> #define SNOR_HWCAPS_READ_1_8_8 BIT(12)
> #define SNOR_HWCAPS_READ_8_8_8 BIT(13)
>