Re: [PATCH] nvme-core: Share code between nvme_wait_ready() and nvme_shutdown_ctrl()

From: Christoph Hellwig
Date: Fri Mar 08 2019 - 08:24:03 EST

On Wed, Feb 06, 2019 at 04:13:12PM -0800, Andrey Smirnov wrote:
> Code polling NVME_CSTS_SHST_CMPLT in nvme_shutdown_ctrl() is very
> similar to polling loop in nvme_wait_ready(). Move shared polling loop
> code into __nvme_wait_ready() and re-implement both
> nvme_shutdown_ctrl() and nvme_wait_ready() on top of it to avoid code
> repetition.

Is there any deeper reason why we would want this? It only saves
6 lines of code, but makes the functions much harder to read.